View Issue Details

IDProjectCategoryView StatusLast Update
0006332ardourbugspublic2015-07-16 12:47
Reporterrgwan Assigned To 
Status newResolutionopen 
Product Version4.0 
Summary0006332: Ardour 4.0 for Windows Cannot import any file
DescriptionThe Ardour 4.0 for Windows(trial version, This computer hasn't compiler.) can't import any file. The "Import" button is disabled. Please take a look at this picture.
TagsNo tags attached.


2015-05-16 05:09


import.png (38,158 bytes)   
import.png (38,158 bytes)   


2015-05-16 13:31

administrator   ~0016689

mmh. I wonder if this is related to the (incomplete) Chinese translation and/or windows UTF-16 filenames. Import works here.

Could you please try if it works with a file that has a simple ASCII filename?

eg. "test.wav" (maybe on a USB stick "D:\test.wav" So that it does not have "C:\some\Chinese\characters\filename"

If that does not help

  Menu > Edit > Preferences > GUI > Disable Translations

re-start ardour, it'll come up in English.


2015-05-16 13:53

reporter   ~0016690

Hmm.I notice that any path with blanket character or non-ASCII character will not be recongized by Ardour for Windows.
It is a pretty simple problem, I think solve it will not take too much time---After my college entrance exam, I will try to solve it if there are still not solve by others:)
As for the bad Chinese translation, in my view, some sentence is too ....rude.
For example "Are you sure?" translate to Chinese just like "What the F**K you want to do?"
So I want to re-translate it into more proper Chinese after my college entrance~


2015-05-16 13:58

reporter   ~0016691

Added, if LADSPA PATH or LV2 path(in enviroment var) has blanket or non-ASCII character, it will not work too....

PS:I don't know why Ardour 's PianoRoll don't display velocity in strip but in color. To draw multiple note 's velocity is not convient as Qtractor or Cubase.....If I add this function, will the patch accept by the Ardour Team?


2015-05-16 14:29

administrator   ~0016692

Thanks for tracking this down.

I'll check whitespace later when I'm close to a win7 box.
(on Linux and OSX there are no problems with space).

As for velocity entry: check out (right click on the record-enable of a midi-track).

Midi-notes are certainly color-coded by velocity.


2015-05-16 14:39

reporter   ~0016693

I mean to display each note 's velocity in strips. Just like most MIDI Editor does.
The velocity is display under the note strip. And long strip shows hi velocity, short strip shows low what I am talking about


2015-05-16 14:48

reporter   ~0016694

Velocity display just like this:


2015-05-16 15:20

administrator   ~0016695

Ah a velocity track. different issue:


2015-05-17 13:50

developer   ~0016697

Importing an audio file with a space in the filename works fine here as long as all the characters are ASCII only on windows 7.

I tried with an audio file that I renamed ??.aif and that did indeed fail to import.

I believe the first problem is that in SndFileSource::get_soundfile_info the filename needs to be converted from utf-8 to the encoding of the current locale using Glib::locale_from_utf8() so that sf_open can open the file.

So I tried that but unfortunately on this system Glib::locale_from_utf8() throws a conversion error for every file with a non-ASCII filename. I'm not sure why at this stage.


2015-05-17 13:55

developer   ~0016698

The filename I use was not "??.aif"

I took an existing audio file and renamed it and used a filename from libs/pbd/test/i18n_test and it failed to import


2015-07-04 08:33

administrator   ~0016837

I guess we should find a way to run those tests...

Since we cross-compile windows binaries the actual system which produces the binaries is not a windows system.

With some effort It would possible to automatically run the tests using wine (and xvfb), but then again the underlying filesystem is still ext3/4 and wine maps the path (using winepath). it's not the real thing.


2015-07-16 11:49

reporter   ~0016893

Believed fixed in Mixbus (Commit #34605a43). If working now, needs to get backported to Ardour.


2015-07-16 12:47

administrator   ~0016894

There's no commit 34605a43 in mixbus git, did you push it?

Issue History

Date Modified Username Field Change
2015-05-16 05:09 rgwan New Issue
2015-05-16 05:09 rgwan File Added: import.png
2015-05-16 13:31 x42 Note Added: 0016689
2015-05-16 13:53 rgwan Note Added: 0016690
2015-05-16 13:58 rgwan Note Added: 0016691
2015-05-16 14:29 x42 Note Added: 0016692
2015-05-16 14:39 rgwan Note Added: 0016693
2015-05-16 14:48 rgwan Note Added: 0016694
2015-05-16 15:20 x42 Note Added: 0016695
2015-05-17 13:50 timbyr Note Added: 0016697
2015-05-17 13:55 timbyr Note Added: 0016698
2015-07-04 08:33 x42 Note Added: 0016837
2015-07-16 11:49 johne53 Note Added: 0016893
2015-07-16 12:47 x42 Note Added: 0016894