View Issue Details

IDProjectCategoryView StatusLast Update
0006262ardourbugspublic2019-07-08 21:20
Reporteroofus Assigned To 
Status newResolutionopen 
Platformi7 3770K 3.5GHz,16GB MemoryOSKubuntuOS Version14.10 64bit
Product Version4.X git (version in description) 
Summary0006262: Exporting a region via the output of its track creates a file with glitching audio.
DescriptionExporting a region via the output of its track creates a file with glitching audio.
Steps To ReproduceRight click the region and select the export option from its context menu. In the resulting export dialogue set the Source to be "Track Outputs". Now export.

My experience has been that a plugin needs to be inserted for the issue to occur. There are reports however that a plugin is not required to trigger the problem.
Additional Information[19/04/2015 18:21:09] <oofus> I seem to be having issues exporting a region when the track it is on has plugins inserted
[19/04/2015 18:22:06] <oofus> the resulting file has low frequency zipper type noise over the real audio
[19/04/2015 18:22:28] <rgareus> oofus: which plugin?
[19/04/2015 18:22:46] <rgareus> oofus: any gain automation on the track?
[19/04/2015 18:23:03] <oofus> rgareus: I've tried a selection, but currently testing with Tap EQ
[19/04/2015 18:23:11] <oofus> rgareus: no automation
[19/04/2015 18:24:07] <oofus> rgareus: I'm exporting from the regions context menu and choosing track output as the ports
[19/04/2015 18:24:17] <oofus> rgareus: ALSA backend
[19/04/2015 18:24:43] <oofus> rgareus: If I remove the plugin the resulting exported audio is clean
[19/04/2015 18:25:51] <oofus> rgareus: it's a stereo track
[19/04/2015 18:27:57] <rgareus> oofus: IIRC "export range" is not a "normal export" (not jack freewheeling, it's a bounce and hence backend independent)
[19/04/2015 18:28:15] <rgareus> oofus: I'll check using SWH's simple amp
[19/04/2015 19:04:39] <rgareus> oofus: I can reproduce it when choosing to export 'track output' of a region. and it also happens without plugin!
[19/04/2015 19:05:35] <rgareus> oofus: but IFF the output has more channels than the region itself (e.g export mono region -> stereo target)
[19/04/2015 19:06:01] <rgareus> oofus: additional channels have glitches
[19/04/2015 19:06:51] <rgareus> oofus: the glitch happens at period-size.
[19/04/2015 19:08:13] <oofus> rgareus: ok, well at least you can reproduce
[19/04/2015 19:08:27] <oofus> rgareus: for me it stops when the plugin is removed or disabled
[19/04/2015 19:08:41] <oofus> rgareus: and it's a stereo region exporting to a stereo file
[19/04/2015 19:08:58] <oofus> rgareus: so no mismatch in port count
[19/04/2015 19:10:50] <rgareus> oofus: I don't know yet. maybe the panner (and buffers)
[19/04/2015 19:11:09] <rgareus> oofus: looks like
[19/04/2015 19:12:15] <rgareus> oofus: that's with a -3dB Simple-Amp post fader, right click on region > Export .. Source: Track output
[19/04/2015 19:12:34] <rgareus> then re-import the region
[19/04/2015 19:13:08] <rgareus> oofus: looks like a sample-rate conversion gone wrong
[19/04/2015 19:13:17] <oofus> rgareus: ok, that looks like the sort of sound I'm hearing
[19/04/2015 19:14:03] <oofus> rgareus: it's 48K session, and I tried exporting to 48K and to 44K1, same issue in both cases
[19/04/2015 19:15:15] <rgareus> oofus: the effect (-3dB in this case) is only applied to the actual channel on export.
TagsNo tags attached.



2019-07-08 21:20

reporter   ~0020692

I just encountered this on Ardour 5.12.0, so confirming that this is still an open issue.This was experienced under the same conditions as already reported (not using jack). Glitches appear every n samples, where n is period size. Session export from master bus is not affected. Sorry if this has already been further discussed elsewhere.

Issue History

Date Modified Username Field Change
2015-04-19 18:34 oofus New Issue
2019-07-08 21:20 jjb Note Added: 0020692