View Issue Details

IDCategoryLast Update
0005830bugs2020-04-19 20:16
ReporterlinuxdspAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version3.0 beta5 
Fixed in Version 
Summary0005830: Ardour defaults to adding new media as new tracks, contrary to the displayed setting
DescriptionCreate a new track, right-click on the track to add an existing media / file to the track, dialogue opens to select the file, file gets added as another new track.
This happens even when the dialogue says the file will be added to the existing track. Can be resolved (sometimes) by selecting another option and then re-selecting add to existing tracks.
Additional InformationBehaviour should match that indicated in the dialogue correctly, default behaviour should be to add the file to the existing track when arrived at by this route since that is implicit in how you arrive at the dialogue e.g. you have to right click on an existing track to get to the dialogue therefore its most likely you want to add the media / file to that track and not create a new one.
TagsNo tags attached.

Activities

ccaudle

2016-08-02 15:47

reporter   ~0018339

Still occurs with 5.0rc1

paul

2016-09-29 13:42

administrator   ~0018727

Is this still an issue?

ccaudle

2016-10-11 03:20

reporter   ~0018783

I notice that in more recent builds there is an option in the add media dialog to add media as new track, add to selected track, add to region list, or add as new tape track. The first time I opened the dialog in a session it defaulted to add as new track, but after I selected add to selected track, the next time I opened the dialog it was already set to add to selected track, so it remembered the last selection. Seems good enough to me.

paul

2016-10-12 21:45

administrator   ~0018793

see notes.

system

2020-04-19 20:16

developer   ~0023298

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2014-01-20 13:35 linuxdsp New Issue
2016-08-02 15:47 ccaudle Note Added: 0018339
2016-09-29 13:42 paul Note Added: 0018727
2016-10-11 03:20 ccaudle Note Added: 0018783
2016-10-12 21:45 paul Note Added: 0018793
2016-10-12 21:45 paul Status new => resolved
2016-10-12 21:45 paul Resolution open => fixed
2016-10-12 21:45 paul Assigned To => paul
2020-04-19 20:16 system Note Added: 0023298
2020-04-19 20:16 system Status resolved => closed