View Issue Details

IDCategoryLast Update
0005805bugs2020-04-19 20:16
ReporterderAbgangAssigned ToderAbgang 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0005805: auto connect preferences not respected for MIDI tracks
Description
Ardour 3.5.146
(built from revision 3.5-148-g8f69af4)

Preferences ->
  Connection of Tracks and Busses

These settings should also apply to MIDI tracks. While "Connect track inputs" is respected for MIDI tracks, "Connect track and bus outputs" isn't.

Seems like just a typo in libs/ardour/session.cc

git diff libs/ardour/session.cc
diff --git a/libs/ardour/session.cc b/libs/ardour/session.cc
index 40123e0..af52163 100644
--- a/libs/ardour/session.cc
+++ b/libs/ardour/session.cc
@@ -1985,7 +1985,7 @@ Session::auto_connect_route (boost::shared_ptr<Route> route, ChanCount& existing
                        for (uint32_t i = output_start.get(*t); i < route->n_outputs().get(*t); ++i) {
                                string port;
 
- if ((*t) == DataType::MIDI || Config->get_output_auto_connect() & AutoConnectPhysical) {
+ if ((*t) == DataType::MIDI && Config->get_output_auto_connect() & AutoConnectPhysical) {
                                        port = physoutputs[(out_offset.get(*t) + i) % nphysical_out];
                                } else if ((*t) == DataType::AUDIO && Config->get_output_auto_connect() & AutoConnectMaster) {
                                         /* master bus is audio only */


TagsNo tags attached.

Activities

derAbgang

2014-01-03 19:54

reporter   ~0015535

Merged 0000065

https://github.com/Ardour/ardour/pull/65

system

2020-04-19 20:16

developer   ~0023297

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2014-01-02 09:25 derAbgang New Issue
2014-01-03 19:54 derAbgang Note Added: 0015535
2014-01-03 19:54 derAbgang Status new => resolved
2014-01-03 19:54 derAbgang Resolution open => fixed
2014-01-03 19:54 derAbgang Assigned To => derAbgang
2020-04-19 20:16 system Note Added: 0023297
2020-04-19 20:16 system Status resolved => closed