View Issue Details

IDCategoryLast Update
0005753bugs2016-10-30 10:05
ReporterMarioAssigned Totimbyr 
Reproducibilityalways 
Status resolvedResolutionfixed 
Product Version 
Fixed in Version5.X git (version in description) 
Summary0005753: Keyboard input breaks group behavior
DescriptionIf you define a group with gain sharing then you can edit gain values (with your keyboard) in the mixer without syncing group members. You can still use the gain sliders though with the expected behavior.
TagsNo tags attached.

Activities

Mario

2013-10-27 11:22

reporter   ~0015467

Just had a look into the code and found this in gain_meter.cc at GainMeterBase::effective_gain_display ()

    if (gain_adjustment.get_value() != value) {
        ignore_toggle = true;
        gain_adjustment.set_value (value);
        ignore_toggle = false;


I'm not sure actually why gain_adjustment.set_value is surrounded by the ignore flags but it works as expected if you just comment both. Alternatively you could add this:

        gain_adjusted ();


As I am not able to write to the git repository, would anybody please take a minute to resolve this?

Mario

2015-12-26 23:55

reporter   ~0017745

This is still an issue in revision 4.4-621-gb1bf6be. Manually typing gain values breaks group behavoir. As this one is more than two years old and it would take just a minute to fix it would be nice if anyone could take the time...

timbyr

2016-10-30 10:04

developer   ~0018876

I can't reproduce this in 5.4 or a nightly build 5.4.226

I'm going to mark this issue as resolved. If the reported tests a recent version and thinks otherwise they can re-open.

Issue History

Date Modified Username Field Change
2013-10-27 06:35 Mario New Issue
2013-10-27 11:22 Mario Note Added: 0015467
2015-12-26 23:55 Mario Note Added: 0017745
2016-10-30 10:04 timbyr Note Added: 0018876
2016-10-30 10:05 timbyr Status new => resolved
2016-10-30 10:05 timbyr Fixed in Version => 5.X git (version in description)
2016-10-30 10:05 timbyr Resolution open => fixed
2016-10-30 10:05 timbyr Assigned To => timbyr