View Issue Details

IDProjectCategoryView StatusLast Update
0005579ardourbugspublic2022-09-11 00:03
Reporterdbolton Assigned Tox42  
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionduplicate 
Product Version3.0 
Summary0005579: Disable "Opaque" option in MIDI regions context menu
DescriptionCurrently all MIDI regions act "transparently" when stacked/overlaid. However context menu shows a checkmark next to "[region name] > Edit > Opaque".

Expected behavior: The "Opaque" menu option should not have a checkmark (since the region acts transparently). Additionally the menu item should be grayed out to indicate that Ardour doesn't support opaque MIDI regions.

Discussion: According to las on IRC, opaque MIDI regions would "present some very, very difficult logic to implement. We would have to synthesize note on and note off events". Since the feature is unlikely to be implemented, the UI should to be updated to reflect this fact.
TagsNo tags attached.

Relationships

related to 0005100 feedbackx42 MIDI regions are always transparent 

Activities

x42

2022-09-11 00:03

administrator   ~0026575

9 years later.. and this has just been implemented.

I'm closing this, please provide feedback at 0005100

Issue History

Date Modified Username Field Change
2013-07-12 05:31 dbolton New Issue
2013-07-12 10:14 colinf Relationship added related to 0005100
2022-09-11 00:03 x42 Note Added: 0026575
2022-09-11 00:03 x42 Assigned To => x42
2022-09-11 00:03 x42 Status new => resolved
2022-09-11 00:03 x42 Resolution open => duplicate