View Issue Details

IDCategoryLast Update
0005545bugs2020-04-19 20:16
Reportertom_Assigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0005545: MIDI Quantize doesn't work
Description
MIDI quantize (main grid) expected result:
-move notes to closest grid position

current behaviour:
-moves notes but not to closest grid position (and not to any grid position at all sometimes)
Additional Information
Could be related to region resize, non-grid moves (?)
TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = US$ 10

2016-04-27 19:39: killermike (US$ 10)
Users sponsoring this issue (Total Sponsorship = US$ 10)

Relationships

has duplicate 0005667 new Midi quantize doesn't always work 

Activities

dabudim

2013-09-15 09:54

reporter   ~0015329

The same happens on me. No matter which grid I choose, Ardour does not move the notes to the right position.

Leatuspenguin

2013-09-15 11:05

reporter   ~0015330

This is a duplicate of 5667. I have found that quantizing regions from the right click menu seems to work but if you don't want to quantize a whole region, it's obviously an issue.

x42

2013-10-23 14:05

administrator   ~0015438

fixed in 3.5-25-g9b086e1 -- please test.

There is still a conceptual issue to be resolved regarding linked midi-regions.
 
The midi-data in the region itself is quantized, but if the region exists multiple times on the timeline (linked regions, shared data), only one of the regions is aligned to the global grid.

Leatuspenguin

2013-10-24 15:11

reporter   ~0015440

I've tested this and still find I'm having the same issues as before. I haven't noticed any differences at all unfortunately.

x42

2013-10-24 20:40

administrator   ~0015443

Thanks for giving it ago.

Odd, it works flawlessly here now. both pressing 'q' on selected notes as well as Region > MIDI > Quantize do the job. I've also tested various grid and quantization settings.

Given the complexity of ardour-midi, I certainly don't doubt that there may be more to it. but there should definitely be a difference (compared to versions before 3.5-24).

I'll add some debug output soon so that we can investigate what and where things go wrong.

Leatuspenguin

2013-10-24 21:43

reporter   ~0015444

" . . .but there should definitely be a difference"

Having spent some more time testing it out, I do think it is more reliable than it used to be. Whereas before it was more miss than hit, I think it's now more hit than miss. It still decides to not quantize from time to time though.

I'm going to spend some more time with it and see if I can recognise any patterns as to when it happens. I'll be in touch if I notice anything interesting.

2013-10-24 23:04

 

Quantize issue.zip (12,959 bytes)

Leatuspenguin

2013-10-24 23:05

reporter   ~0015445

Ok, i've attached a session which is affected by the issue. I have been able to open this session up on up to date builds of Ardour on both Avlinux and Debian wheezy so it seems the issue is consistent. When you open up the session you, hopefully, should not be able to quantize selections of notes using the Q shortcut. Hopefully it'll give some insight to this issue.

x42

2013-10-25 11:29

administrator   ~0015447

yes, I can reproduce it.

I get lots of "note XX/Y was already on" messages, too. which is generally not a good omen. The actual problem is underneath.

In this case. Moving the region-end further to the right so that all notes are completely inside the region and properly terminated, makes quantization of individual notes work (again).

There are still some very odd cases. I'll investigate further. This test session is going to come in handy.

In any case, if the quantization dialog comes up and moves notes, the notes always end up properly on the grid now.

On the downside, it can create more overlapping notes. ie "note XX/Y was already on" mess and sometimes the quantization-dialog does not show in the first place. rather strikes me as a problem with midi regions in general than quantization specifically.

2015-03-03 14:04

 

Quantize Debug.zip (186,668 bytes)

robertnyles

2015-03-03 14:06

reporter   ~0016390

Last edited: 2015-03-03 14:07

I uploaded a session where I thought quantize would work but then I realized that most notes are a very small amount before the grid/beat. I can't reproduce it in another session. So I removed all audio in that session.

Ardour 3.5.4587

killermike

2016-04-27 19:25

reporter  

ardour_quan_example.tar.gz (960,624 bytes)

killermike

2016-04-27 19:31

reporter   ~0018160

I'm having this problem too, and it's blocking me from using Ardour for MIDI work. I have attached a file that exhibits this problem (ardour_quan_example.tar.gz)

I have been working with Ardour 4.7 but I had a go with a Ardour build from the latest source a couple of weeks ago (April 12 2016) with the same results.

Some of the notes in the sequencer fail to quantize or quantize inconsistently when I try to quantize via the main menu or right click menu. This is evident in the second, third and four chords in the example. When I examine the notes by right clicking on them while in draw mode, they are always slightly forward and have something|something|1920 (rather than something|something|0000) for the position. This makes it difficult when looping or cutting and pasting, although they always seem to stay within their proper region when moved about.

Even moving the note when in draw mode and then moving it back with snap mode enabled only works inconsistently. It's almost as if part of the software seems to be storing correct values for note start times.

Note that the tempo of the attached file is 123 bpm.

killermike

2016-09-08 08:12

reporter   ~0018570

I've been using Ardour 5.3 for a couple of days and I haven't noticed any problems with the quantise. Looks like this one's fixed. Thanks guys.

paul

2016-09-09 23:19

administrator   ~0018587

see notes. feel free to reopen if it actually isn't fixed.

system

2020-04-19 20:16

developer   ~0023247

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2013-06-22 18:54 tom_ New Issue
2013-09-15 09:54 dabudim Note Added: 0015329
2013-09-15 11:05 Leatuspenguin Note Added: 0015330
2013-10-23 14:05 x42 Note Added: 0015438
2013-10-23 14:05 x42 Assigned To => x42
2013-10-23 14:05 x42 Status new => feedback
2013-10-23 14:06 x42 Relationship added has duplicate 0005667
2013-10-24 15:11 Leatuspenguin Note Added: 0015440
2013-10-24 20:40 x42 Note Added: 0015443
2013-10-24 21:43 Leatuspenguin Note Added: 0015444
2013-10-24 23:04 Leatuspenguin File Added: Quantize issue.zip
2013-10-24 23:05 Leatuspenguin Note Added: 0015445
2013-10-25 11:29 x42 Note Added: 0015447
2015-01-14 23:29 x42 Assigned To x42 =>
2015-03-03 14:04 robertnyles File Added: Quantize Debug.zip
2015-03-03 14:06 robertnyles Note Added: 0016390
2015-03-03 14:07 robertnyles Note Edited: 0016390
2016-04-27 19:25 killermike File Added: ardour_quan_example.tar.gz
2016-04-27 19:31 killermike Note Added: 0018160
2016-04-27 19:39 killermike Sponsorship Added killermike: US$ 10
2016-04-27 19:39 killermike Sponsorship Total 0 => 10
2016-09-08 08:12 killermike Note Added: 0018570
2016-09-09 23:19 paul Note Added: 0018587
2016-09-09 23:19 paul Status feedback => resolved
2016-09-09 23:19 paul Resolution open => fixed
2016-09-09 23:19 paul Assigned To => paul
2020-04-19 20:16 system Note Added: 0023247
2020-04-19 20:16 system Status resolved => closed