View Issue Details

IDProjectCategoryView StatusLast Update
0005257ardourbugspublic2013-01-14 09:50
Reporterdanson_13 Assigned To 
Status newResolutionopen 
Product Version2.8.14 
Summary0005257: Hang at "Setup signal flow and plugins" upon loading previous session
DescriptionArdour is hanging upon attempting to load previously saved sessions. Upon launching from either the desktop or the terminal and attempting to load a previous project, Ardour hangs at "Setup signal flow and plugins". It also brings down Jack and it then becomes (seemingly) impossible to kill the Jack process. In order to restart Jack, a reboot is necessary.

Steps to reproduce:
- Boot machine and start Jack via Qjackctl
- Launch Ardour either via desktop or terminal
- Attempt to load previous project
- Ardour will hang at the "Setup signal flow and plugins" stage, approximately 9/10 times

Other observations:
- Approximately 1/10 times or less, I will be able to load the session, following the above steps exactly. As this is straight from boot-up, I can't think of any particular variables which might influence this
- I am able to create a new project with no problems; it's only when re-loading a previously saved session that problems occur
- The problem does not appear to be specific to one "rogue" session. I've tried a variety of sessions, both recent (saved the day before) and non-recent (over 6 months ago), and the problem still occurs
Additional InformationAfter searching various forums, I've tried the below, but without success.

- Removing the config file before re-loading the session
- Removing/reinstalling LADSPA/LV2 plug-ins, even removing all plug-ins
- Switching desktop theme to Raleigh, as per this thread:

System/version info:

- Open SuSE 12.2 64 bit, with kernel-desktop 3.4.11-2.16.1 from the SuSE repos
- XFCE 4 (also tried KDE 4 with the same effect)
- Jack 1.9.8-56.1 and Qjackctl 0.3.9-21.4 from the SuSE repos
- Tried Ardour 2.8.13-2.16-x86_64 from the SuSE repos, plus 2.8.16_13591 downloaded from the Ardour site (please note that the Mantis "Product Version" drop down box does not have either of these versions, so I've set it to 2.8.14). I also tried a beta version of Ardour 3 from the SuSE repos (ardour3-3.0b5-13159.2.x86_64) and encountered the same problem


1) Ardour2_DissonantDance.ardour
Sample session file with which I encounter the problem. It was originally created using Ardour 2.8.13-2.16-x86_64, within the last couple of days
2) consoleoutput.txt
Sample console output, up to the point of the crash
3) gbdoutput.txt
Backtrace using gdb. Please note that I'm not entirely sure I've done this correctly, as per the information about debugging on the Ardour site. When Ardour hangs, the gdb prompt does not appear; I have to kill the Ardour process and only then can I run "thread apply all bt". With this in mind, I'm not sure if the information is useful or not. Please also note that I had to build with SYSLIBS=1, as per the information here:
TagsNo tags attached.


2013-01-06 07:19


danson_13.tar.gz (11,411 bytes)


2013-01-06 13:10

reporter   ~0014433

This seems like this bug:
The workaround was to compile jack without optimization (-O0). The current Fedora jack package is compiled without optimization and it works.
I would suggest to try to compile jack with -O0 and see if it works.


2013-01-07 13:45

reporter   ~0014436

Thank you for the information - yes, it does sound like it could be the same issue.

I looked into compiling Jack, but the website had a strenuous warning about not having two versions installed at the same time; and attempting to remove my packaged version gave me 600+ dependency problems. The website does give instructions on how to install over the top of an existing version, but I don't want to chance messing up my machine at the moment, as I need to finish my current project. I'm continuing on in Qtractor for the moment, but will have another look at this in the future when I'm able to.

I suppose that if this bug is really a Jack issue, rather than an Ardour issue, it could be closed here (unless the developers think it's something which needs to be taken into consideration?).


2013-01-13 09:21

reporter   ~0014464

I've now found time to test this out and your advice worked. I've started and stopped Ardour over 30 times in succession, loading a variety of projects, old and new (including the one mentioned in this report), and encountered no problems whatsoever. Thanks very much for the help :-)


2013-01-14 09:50

reporter   ~0014465

This seems to be related to gcc bug

I think it's not fully resolved yet.

Issue History

Date Modified Username Field Change
2013-01-06 07:19 danson_13 New Issue
2013-01-06 07:19 danson_13 File Added: danson_13.tar.gz
2013-01-06 13:10 tartina Note Added: 0014433
2013-01-07 13:45 danson_13 Note Added: 0014436
2013-01-13 09:21 danson_13 Note Added: 0014464
2013-01-14 09:50 tartina Note Added: 0014465