View Issue Details

IDCategoryLast Update
0005237bugs2020-04-19 20:16
ReporterprokoudineAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0005237: Loop playback doesn't work for MIDI
Description1. Create a MIDI track, assign an instruments, e.g. Calf Organ
2. Add some notes to a MIDI region.
3. Set loop playback mode.
4. Start playing.

A3 will only send MIDI notes once. As soon as it returns to the beginning, it stops sending notes to the plug-in.
TagsNo tags attached.

Relationships

duplicate of 0005050 closedpaul Problem looping midi 
related to 0004168 closedpaul when synced to JACK-transport: loop-playback loops only once or never. 
related to 0006140 closedccaudle first loop playback is incorrect, subsequent are correct 

Activities

2013-01-23 02:12

 

Trrrrr.tar.bz2 (10,240 bytes)

prokoudine

2013-01-23 02:16

reporter   ~0014570

The attached test session (using setBfree as an LV2 instrument) is an example of incorrect behaviour. Both end loop and end session markers are slightly beyond the end of the MIDI clip, so A3 should send note-off, go to the end and return to the beginning. It only happens the first time the loop is played. Sending note-off doesn't really work the second time A3 reaches the end of the clip.

Sorry about localized marker names, but pressing L is universal anyway :)

Leatuspenguin

2013-01-23 12:29

reporter   ~0014574

I noticed this bug awhile back too but it has since been fixed, for me at least. I opened up your session and had no problem with midi while looping it. What build are you using. Latest revision is 13974.

x42

2016-06-08 21:40

administrator   ~0018242

Can no longer reproduce with Ardour 4.7 - closing

There have been quite a few changes to midi-looping since.

system

2020-04-19 20:16

developer   ~0023173

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2012-12-31 00:35 prokoudine New Issue
2013-01-02 23:25 paul Relationship added duplicate of 0005050
2013-01-02 23:26 paul Relationship added related to 0004168
2013-01-23 02:12 prokoudine File Added: Trrrrr.tar.bz2
2013-01-23 02:16 prokoudine Note Added: 0014570
2013-01-23 12:29 Leatuspenguin Note Added: 0014574
2015-01-22 16:23 x42 Relationship added related to 0006140
2016-06-08 21:40 x42 Note Added: 0018242
2016-06-08 21:40 x42 Status new => resolved
2016-06-08 21:40 x42 Resolution open => fixed
2016-06-08 21:40 x42 Assigned To => x42
2020-04-19 20:16 system Note Added: 0023173
2020-04-19 20:16 system Status resolved => closed