View Issue Details

IDCategoryLast Update
0004920bugs2019-04-26 13:07
Reporterjohan_mattsson_mAssigned Tocth103 
Reproducibilityalways 
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0004920: Ardour refuses to load some projects
DescriptionArdour refuses to load some projects because:

ardour-3.0: ../libs/pbd/pbd/sequence_property.h:202: PBD::SequenceProperty<Container>* PBD::SequenceProperty<Container>::clone_from_xml(const XMLNode&) const [with Container = std::list<boost::shared_ptr<ARDOUR::Region>, std::allocator<boost::shared_ptr<ARDOUR::Region> > >]: Försäkran "v" falsk.

It seems to be an undo transaction in the history file without any changes that prevents this session from being loaded.
Additional InformationPatch included.
TagsNo tags attached.

Activities

2012-06-09 22:39

 

allow_empty_undo_transactions_in_sequence_property.diff (714 bytes)
Index: libs/pbd/pbd/sequence_property.h
===================================================================
--- libs/pbd/pbd/sequence_property.h	(revision 12638)
+++ libs/pbd/pbd/sequence_property.h	(arbetskopia)
@@ -199,9 +199,10 @@
 		for (XMLNodeList::const_iterator j = grandchildren.begin(); j != grandchildren.end(); ++j) {
 
 			typename Container::value_type v = get_content_from_xml (**j);
-			assert (v);
-			
-			if ((*j)->name() == "Add") {
+
+			if (!v) {
+				std::cerr << "Warning undo transactions does not contain any changes." << std::endl;
+			} else if ((*j)->name() == "Add") {
 				p->_changes.added.insert (v);
 			} else if ((*j)->name() == "Remove") {
 				p->_changes.removed.insert (v);

cth103

2012-06-09 23:11

administrator   ~0013454

Hi, thanks very much for the patch! We think we've fixed the root cause of this problem now, so hopefully this won't happen any more. I'll think about whether to apply the patch as a backup.

johan_mattsson_m

2012-06-09 23:42

reporter   ~0013457

Sounds great. Thanks

cth103

2012-06-25 21:19

administrator   ~0013709

OK, I applied the patch to SVN 12930. Thankyou very much!

Issue History

Date Modified Username Field Change
2012-06-09 22:39 johan_mattsson_m New Issue
2012-06-09 22:39 johan_mattsson_m File Added: allow_empty_undo_transactions_in_sequence_property.diff
2012-06-09 23:11 cth103 Note Added: 0013454
2012-06-09 23:11 cth103 cost => 0.00
2012-06-09 23:11 cth103 Target Version => 3.0
2012-06-09 23:42 johan_mattsson_m Note Added: 0013457
2012-06-25 20:34 cth103 Status new => acknowledged
2012-06-25 21:19 cth103 Note Added: 0013709
2012-06-25 21:19 cth103 Status acknowledged => resolved
2012-06-25 21:19 cth103 Resolution open => fixed
2012-06-25 21:19 cth103 Assigned To => cth103