View Issue Details

IDProjectCategoryView StatusLast Update
0004898ardourbugspublic2012-06-05 12:41
Reportertriune Assigned To 
Status feedbackResolutionopen 
Product Version3.0 beta4 
Target Version3.0 
Summary0004898: undefined symbol: pixman_image_composite32
DescriptionArdour3.0beta4a (built using ['12406'] and GCC version 4.4.6)
/usr/share/themes/ClearlooksClassic/gtk-2.0/gtkrc:75: error: unexpected identifier `reliefstyle', expected character `}'
CONFIG PATH: /home/g/.config/ardour3:/opt/Ardour-3.0beta4a_12406/etc
ardour: [INFO]: Loading default ui configuration file /opt/Ardour-3.0beta4a_12406/etc/ardour3_ui_default.conf
Loading user ui configuration file /opt/Ardour-3.0beta4a_12406/etc/ardour3_ui.conf
ardour: [INFO]: Loading ui configuration file /opt/Ardour-3.0beta4a_12406/etc/ardour3_ui_dark.rc
/usr/share/themes/ClearlooksClassic/gtk-2.0/gtkrc:75: error: unexpected identifier `reliefstyle', expected character `}'
ardour: [INFO]: Ardour will be limited to 1024 open files
ardour: [INFO]: Loading system configuration file /opt/Ardour-3.0beta4a_12406/etc/ardour_system.rc
Loading user configuration file /home/g/.config/ardour3/ardour.rc
Using SSE optimized routines
ardour: [INFO]: looking for panners in /home/g/.config/ardour3/panners:/opt/Ardour-3.0beta4a_12406/lib/panners
ardour: [INFO]: Panner discovered: "VBAP 2D panner" in /opt/Ardour-3.0beta4a_12406/lib/panners/
ardour: [INFO]: Panner discovered: "Mono to Stereo Panner" in /opt/Ardour-3.0beta4a_12406/lib/panners/
ardour: [INFO]: Panner discovered: "Equal Power Stereo" in /opt/Ardour-3.0beta4a_12406/lib/panners/
DATA PATH: /home/g/.config/ardour3:/opt/Ardour-3.0beta4a_12406/share
LV2: Discovering 269 plugins
Failed to expand qname `foaf:name'
Attempt to add quad with NULL field.
Failed to expand qname `foaf:homepage'
Attempt to add quad with NULL field.
Failed to expand qname `foaf:mbox'
Attempt to add quad with NULL field.
Done LV2 discovery
/opt/Ardour-3.0beta4a_12406/bin/ardour-3.0: symbol lookup error: /opt/Ardour-3.0beta4a_12406/lib/ undefined symbol: pixman_image_composite32
Additional Informationardour3 beta 3 did not have this problem and worked great :)
TagsNo tags attached.



2012-06-01 17:19

administrator   ~0013347

this has recently been identified as caused by a missing step in the linux packaging step, and has been fixed. If you are on a 64bit platform, then try out: and report back on whether it fixes the issue.


2012-06-02 20:29

reporter   ~0013359

Ardour_64bit-3.0beta4a_12523 Fixed this issue for me. I Can now start Ardour in Debian x86_64 GNU/Linux.


2012-06-05 11:42

reporter   ~0013386

Confirmed to work for me as well on Ubuntu 10.04+KxStudio x86_64 :)


2012-06-05 12:41

administrator   ~0013387

this (or a very similar bug) is still not solved on 32 bit builds, because using patchelf(1) to alter RPATH within the libraries causes strip(1) to malfunction.

Issue History

Date Modified Username Field Change
2012-05-31 03:38 triune New Issue
2012-05-31 14:07 cth103 cost => 0.00
2012-05-31 14:07 cth103 Target Version => 3.0
2012-06-01 17:19 paul Note Added: 0013347
2012-06-01 17:19 paul Status new => feedback
2012-06-02 20:29 josku Note Added: 0013359
2012-06-05 11:42 triune Note Added: 0013386
2012-06-05 12:41 paul Note Added: 0013387