View Issue Details

IDProjectCategoryView StatusLast Update
0004524ardourbugspublic2012-11-13 15:32
Reporterjmb8710 Assigned To 
Status confirmedResolutionopen 
Product Version3.0-beta1 
Target Version3.0 
Summary0004524: Autotalent reliably causes Ardour 3 to be kicked by JACK when 'formant correction' is enabled
DescriptionWhen testing out the Autotalent LADSPA auto-tune plugin in a self-compiled SVN snapshot of Ardour 3, I found that whenever I enabled Autotalent's formant correction option (button on far left of GUI) Ardour would be kicked by JACK for being too slow as soon as I clicked the 'stop' transport button.

Of course, I thought this was a bug in Autotalent, but I tried doing the same thing in the version of Ardour 2 in the Ubuntu repositories and the problem does not occur.

I am quite new to Ardour and JACK so I'm not sure, but I think this is an Ardour 3 bug.
Additional InformationUsing Ubuntu 11.10 Onieric on AMD64. Tried with both motherboard-integrated soundcard and a Creative Audigy - the problem occurs with both. All my memlock, rtprio and nice limits are properly set up for Ardour.

  Users sponsoring this issue
Sponsors List Total Sponsorship = US$ 5

2011-12-01 21:11: jmb8710 (US$ 5)
  Users sponsoring this issue (Total Sponsorship = US$ 5)



2011-12-01 19:01

reporter   ~0012254

Sorry, forgot to mention:

[Thu Dec 01 19:01:04] james@blackbull:~$ jackd --version
jackd version 0.121.0 tmpdir /dev/shm protocol 24


2011-12-01 21:35

reporter   ~0012261

Last edited: 2011-12-01 21:36

UPDATE: Stupidly, I didn't test this out with JACK 2 until now. Sorry, I'm new to this... I'm pleased to say it works *slightly* better, except that when I hit stop or play:

1. The log window pops up with a few instances of the following message:
[ERROR]: JACK: JackActivationCount::Signal value = 0 ref = 2
2. The audio runs too fast for up to several seconds

Furthermore, while I've been typing this my system has been unresponsive for short periods of time while Ardour and the loaded Autotalent instance have been idling in the background. Deleting the Autotalent instance seems to cure this.

JACK is reporting underruns on the console still, but Ardour seems to be better at clinging on to a connection.
JackEngine::XRun: client = ardour was not run: state = 1
JackAudioDriver::ProcessGraphAsync: Process error

I'll try doing the same thing in Ardour 2 and report back, just to ensure it's not a problem with my system.


2011-12-01 22:00

reporter   ~0012262

Doing exactly the same thing in Ardour 2 works flawlessly. No skipping, no peculiar console output, nothing. If I'm not mistaken, this does seem to be an Ardour 3 problem.

Hope all this info is useful.


2011-12-13 02:22

administrator   ~0012402

i wonder if its trying to add a new port to get formant information. ardour2 would just ignore that, whereas ardour3 would probably pay attention to it.

you need to check with the developer of autotalent what this control (format correction) does...

also, jack2 is not a "newer, better, later" version of jack1. its an alternative implementation. see the FAQ at for more on this. the error message you got is a bug in jack2 and is fixed in an upcoming release of jack2.


2011-12-26 22:37

administrator   ~0012461

I think this is a denormal problem in autotalent. I've mailed the author to enquire.


2012-11-13 02:47

administrator   ~0014230

cth103: did you ever hear back?


2012-11-13 15:32

reporter   ~0014241

Paul: this is no longer a problem in the latest beta.

Issue History

Date Modified Username Field Change
2011-12-01 18:59 jmb8710 New Issue
2011-12-01 19:01 jmb8710 Tag Attached: 3.0
2011-12-01 19:01 jmb8710 Note Added: 0012254
2011-12-01 20:04 cth103 cost => 0.00
2011-12-01 20:04 cth103 Target Version => 3.0-beta2
2011-12-01 21:11 jmb8710 Sponsorship Added jmb8710: US$ 5
2011-12-01 21:11 jmb8710 Sponsorship Total 0 => 5
2011-12-01 21:35 jmb8710 Note Added: 0012261
2011-12-01 21:36 jmb8710 Note Edited: 0012261
2011-12-01 22:00 jmb8710 Note Added: 0012262
2011-12-13 02:22 paul Note Added: 0012402
2011-12-26 19:53 cth103 Status new => confirmed
2011-12-26 22:37 cth103 Note Added: 0012461
2012-01-10 20:45 cth103 Target Version 3.0-beta2 => 3.0-beta3
2012-02-14 17:20 paul Target Version 3.0-beta3 => 3.0 beta4
2012-05-23 15:09 cth103 Target Version 3.0 beta4 => 3.0
2012-11-13 02:47 paul Note Added: 0014230
2012-11-13 15:32 jmb8710 Note Added: 0014241