View Issue Details

IDCategoryLast Update
0004388bugs2011-11-22 00:37
ReporteroofusAssigned Tocth103 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformDell D830 core2duo T9300 2.5GHzOSKubuntuOS Version11.10
Product Version 
Fixed in Version3.0-beta2 
Summary0004388: When a session has a midi track in it, the playback buffer indication on the tool bar always shows 0% when playing.
DescriptionWhen a session has a midi track in it, the playback buffer indication on the tool bar always shows 0% when playing.
TagsNo tags attached.

Activities

cth103

2011-10-24 20:08

administrator   ~0011767

This is because when there is no more MIDI data on a track MidiDiskstream::playback_buffer_load returns 0 as there is nothing to read in _playback_buf.

cth103

2011-11-15 18:05

administrator   ~0012056

Fixed in SVN 10619.

oofus

2011-11-22 00:37

developer   ~0012177

Fixed, thanks

Issue History

Date Modified Username Field Change
2011-10-23 12:44 oofus New Issue
2011-10-23 12:44 oofus cost => 0.00
2011-10-23 18:37 cth103 Status new => confirmed
2011-10-23 18:37 cth103 Target Version => 3.0-beta1
2011-10-24 20:08 cth103 Note Added: 0011767
2011-11-14 15:55 cth103 Target Version 3.0-beta1 => 3.0-beta2
2011-11-15 18:05 cth103 Note Added: 0012056
2011-11-15 18:05 cth103 Status confirmed => resolved
2011-11-15 18:05 cth103 Fixed in Version => 3.0-beta2
2011-11-15 18:05 cth103 Resolution open => fixed
2011-11-15 18:05 cth103 Assigned To => cth103
2011-11-22 00:37 oofus Note Added: 0012177
2011-11-22 00:37 oofus Status resolved => closed