View Issue Details

IDCategoryLast Update
0004168bugs2020-04-19 20:15
Reporterx42Assigned Topaul 
Reproducibilityalways 
Status closedResolutionwon't fix 
Product Version 
Fixed in Version 
Summary0004168: when synced to JACK-transport: loop-playback loops only once or never.
DescriptionThe "Play-Loop-range" function is behaving weird and inconsistent when ardour is synced to JACK-transport.

preparation:
 * create a new session
 * record a short audio track -> session/loop start/end markers

with "Internal Sync"
 * press "loop play" -> loops forever
 * press stop

now switch to "JACK Sync"
 * seek to some time (inside the looped range) by clicking on the timeline.
 * press "loop play" -> loops once, then disables loop playback and keeps going.


The actual bug /might/ be: re-locating by clicking in the timeline does not check the active sync-source and allows to loop even though ardour is synced to JACK-transport.

If the loop-range is NOT identical to the session-range: rewinding and pressing loop will make ardour3 loop the region exactly once with jack-transport. But if the loop-range and session-range start-positions are identical: play-loop-range can not be activated after a "rewind" iff ardour is synced to JACK-transport. Ardour then selects the loop but the transport does not start rolling. Subsequently pressing "Play" in ardour resets the loop-mode. However pressing "Play" in qjackctl (or any other jack-transport client) will allow to loop once..


I'd prefer if looping would also be available with JACK-transport (even though there is a short gap when looping). - The motivation for that is not live-sequencing (where the gap would be relevant) but post-production and composition (a small gap makes no difference) where looping a region for tweaking effect params, listening tests, etc is a very important feature as is JACK-transport sync.
Additional Informationardour3 - alpha9 - svn9809
TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = US$ 50

2014-02-23 19:17: danryu (US$ 5)
2014-03-02 14:02: aowron (US$ 25)
2014-05-13 13:03: gravy (US$ 5)
2016-06-08 21:04: m_edel (US$ 15)
Users sponsoring this issue (Total Sponsorship = US$ 50)

Relationships

related to 0005050 closedpaul Problem looping midi 
related to 0005237 closedx42 Loop playback doesn't work for MIDI 
related to 0006140 closedccaudle first loop playback is incorrect, subsequent are correct 

Activities

nettings

2011-12-03 01:53

manager   ~0012286

same here. sync to internal, loop works as expected. sync to jack transport, loop works once, and then ardour continues to play.

cajmere

2012-09-18 18:46

reporter   ~0014025

I can confirm it. The internal/jack button start blinking also, and on commandline a get these lines:

"ARDOUR says 331264 JACK says 331520
ARDOUR says 331520 JACK says 331648
ARDOUR says 331520 JACK says 331776
ARDOUR says 331776 JACK says 331904
ARDOUR says 331776 JACK says 332032
ARDOUR says 332032 JACK says 332160
ARDOUR says 332032 JACK says 332288
ARDOUR says 332032 JACK says 332416
ARDOUR says 332416 JACK says 332544
ARDOUR says 332416 JACK says 332672
ARDOUR says 332672 JACK says 332800"

I think it's maybe related to bug 0005050: Problem looping midi

paul

2012-12-20 01:32

administrator   ~0014380

looping *is* available with JACK transport, just not "seamless". there is an option in preferences.

nettings

2013-01-22 22:16

manager   ~0014567

no, you misunderstood.
if "seamless looping" is active in the prefs, a3 will not let you engage looping at all, and prints a rather clear and helpful message to that effect.
the issue at hand is about non-seamless looping.

to reproduce: switch transport from internal to jack.
select a range, loop range.
observe how the range is played, and then playing continues after the range rather than jumping back to the beginning of the loop range.

nettings

2013-04-06 23:24

manager   ~0014836

bumping this one to bring it to paul's attention again...

danryu

2014-02-23 19:18

reporter   ~0015681

Would love to see this fixed ... for looping a midi region in ardour with the corresponding section in a hydrogen pattern, for example.

eddrog

2014-02-23 20:20

reporter   ~0015682

1+

aowron

2014-02-28 22:13

reporter   ~0015695

Would love to see this fixed too; this issue basically makes it impossible to use ardour with hydrogen (which by the way works JACK-synced with for example Qtractor).

domohawk

2014-05-05 09:24

reporter   ~0015781

Also would like to see this fixed. My friend I introduced to ardour was quite frustrated that looping wasn't working, until I realized he had for some reason enabled Jack sync in his session and was informed of this bug in irc.

m_edel

2016-06-08 21:05

reporter   ~0018239

still an issue in ardour 4.6.0

x42

2016-06-08 21:19

administrator   ~0018241

How can this still be an issue?

Ardour since version 4.4.485 should not allow to loop the transport when synced to JACK.

Mainly because jack-transport does not support looping and trying to work around this conceptual shortcoming - even if it can work sometimes - is doomed to fail.

m_edel

2016-06-09 20:44

reporter   ~0018245

The loop-button and the shortcut ('L') are disabled when using jack transport, but you still can rightclick a region and choose 'loop'.

Still, having a workaround would improve usability a lot in my opinion.

x42

2016-06-09 20:58

administrator   ~0018246

right click and loop range/region only sets the range but does not initiate loop playback (at least with 4.7-git, 5.0-pre)

x42

2016-06-09 21:00

administrator   ~0018247

PS. I initially reported the bug, all those years ago, I was not aware of jack's limitations WRT to loop playback at that point in time.

system

2020-04-19 20:15

developer   ~0022655

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2011-07-11 19:37 x42 New Issue
2011-07-11 21:15 cth103 cost => 0.00
2011-07-11 21:15 cth103 Target Version => 3.0-beta1
2011-11-15 15:00 cth103 Target Version 3.0-beta1 => 3.0-beta2
2011-12-03 01:53 nettings Note Added: 0012286
2011-12-03 01:53 nettings Status new => confirmed
2012-01-10 20:46 cth103 Target Version 3.0-beta2 => 3.0-beta3
2012-02-14 17:20 paul Target Version 3.0-beta3 => 3.0 beta4
2012-05-23 15:09 cth103 Target Version 3.0 beta4 => 3.0
2012-09-18 18:46 cajmere Note Added: 0014025
2012-12-20 01:32 paul Note Added: 0014380
2013-01-02 23:26 paul Relationship added related to 0005050
2013-01-02 23:26 paul Relationship added related to 0005237
2013-01-22 22:16 nettings Note Added: 0014567
2013-04-06 23:24 nettings Note Added: 0014836
2013-04-06 23:24 nettings Assigned To => paul
2013-04-06 23:24 nettings Status confirmed => feedback
2014-02-23 19:17 danryu Sponsorship Added danryu: US$ 5
2014-02-23 19:17 danryu Sponsorship Total 0 => 5
2014-02-23 19:18 danryu Note Added: 0015681
2014-02-23 20:20 eddrog Note Added: 0015682
2014-02-28 22:13 aowron Note Added: 0015695
2014-03-02 14:02 aowron Sponsorship Added aowron: US$ 25
2014-03-02 14:02 aowron Sponsorship Total 5 => 30
2014-05-05 09:24 domohawk Note Added: 0015781
2014-05-13 13:03 gravy Sponsorship Added gravy: US$ 5
2014-05-13 13:03 gravy Sponsorship Total 30 => 35
2015-01-22 16:21 x42 Relationship added child of 0006140
2015-01-22 16:22 x42 Relationship replaced related to 0006140
2016-06-08 21:04 m_edel Sponsorship Added m_edel: US$ 15
2016-06-08 21:04 m_edel Sponsorship Total 35 => 50
2016-06-08 21:05 m_edel Note Added: 0018239
2016-06-08 21:19 x42 Note Added: 0018241
2016-06-08 21:19 x42 Status feedback => assigned
2016-06-08 21:19 x42 Status assigned => resolved
2016-06-08 21:19 x42 Resolution open => won't fix
2016-06-09 20:44 m_edel Note Added: 0018245
2016-06-09 20:58 x42 Note Added: 0018246
2016-06-09 21:00 x42 Note Added: 0018247
2020-04-19 20:15 system Note Added: 0022655
2020-04-19 20:15 system Status resolved => closed