View Issue Details

IDCategoryLast Update
0001691bugs2019-07-14 18:06
ReporterzettberlinAssigned To 
Reproducibilityalways 
Status resolvedResolutionfixed 
Product Version2.0 
Fixed in Version 
Summary0001691: MMC and MTC do not work on Linux with Muse or Rosegarden
DescriptionAll my attempts to sync Ardour witch Muse or Rosegarden on Linux failed. The only way is to use jack but this works not very good. MMC and MTC are not able to sync ardour neitehr as slave or master.

If this is a known issue and the decision has been made to rely on jack to sync apps on Linux please drop me a line and I accept it...
TagsNo tags attached.

Activities

paul

2007-05-22 22:11

administrator   ~0004011

Given that MTC and MMC have been shown to sync Ardour to external hardware with astounding responsivity, it seems natural to suspect MuSE and/or Rosegarden.

But before we do that, why don't you first explain in excessive detail what you actually tried to do.

zettberlin

2007-05-22 23:09

reporter   ~0004012

>suspect MuSE and/or Rosegarden.

I am pretty sure, that they are suspect indeed, still it is an issue and I remember syncing Muse to 0.99 worked somwhat better then syncing with ardour2


> But before we do that, why don't you first explain in excessive detail what you actually tried to do.

Allright, the details:

Muse 0.9pre2:

Ardour is set to use MMC, being Time Master, clock internal
Ardour runs OK, Muse does nothing, regardelesss if being set to Slave or Master

vice-versa Ardour does not react, if Muse is Master and sends MTC and/or MMC, regardeless if Ardour is set to be Time Master or not and if the clock is set to MTC or internal - simply no reaction

Rosegarden 1.5.1:

RG is set to Master, Ardour clock is MTC.

clicking Play in RG plays in RG, no response from Ardour after 3-4 times hitting Play in RG Ardour shows up the following message:

[ERROR]: Unknown rate/drop value in incoming MTC stream, session values used instead

so Chris and Michael might be the bad boys here. I never tried syncing RG and Ardour before, so I do not know if any regressions have appeared --- this is different with Muse, I had Muse 0.8x successfully synced to ardour 0.99 last year.

Anyways: Muse syncs OK with Ardour via jack, RG syncs the start if set to sync with jack but does not react to changes in the position of the cursor in Ardour - that is: hitting Play in Ardour if RG is connected allways starts both programs at the beginning of the timeline. If Ardour is ordered to play a looprange, it does - but RG starts at the beginning of its own loop (even if it is set to be slave to any sync-sources) and Ardour plays the loop just once and then it jumps back to the start and continues playing.

I guess, all this is mainly an issue with RG and Muse. But since syncing to a MIDI-Sequencer is important to many people, I think those people should be notified, that there are problems with the most popular Sequencers in Linux and that it is recommended to use Muse synced via jack (that worked best for me so far).

seablade

2009-07-05 03:49

manager   ~0006306

Resolving this out as it is believed to have been an issue with Muse and/or RG. Not even sure if it still applies.

Issue History

Date Modified Username Field Change
2007-05-21 22:11 zettberlin New Issue
2007-05-22 22:11 paul Note Added: 0004011
2007-05-22 22:11 paul Status new => feedback
2007-05-22 23:09 zettberlin Note Added: 0004012
2009-07-05 03:49 seablade Note Added: 0006306
2009-07-05 03:49 seablade Status feedback => resolved
2009-07-05 03:49 seablade Resolution open => fixed
2009-07-05 03:49 seablade Description Updated
2009-07-05 03:49 seablade Additional Information Updated