MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007664ardourbugspublic2018-09-19 12:252018-09-19 23:45
Reporterunfa 
Assigned Tox42 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformPCOSLinux MintOS Version18.3
Product Version5.12 
Target VersionFixed in Version 
Summary0007664: Ardour will fail to load a session if the absolute path contains a colon character
DescriptionYesterday I've renamed a folder containing my Arodur Session to have a colon (':') in it.

Today I tried loading my session and Ardour reported it can't find some MIDI files. I said skip all - it coulnd't find any of them, my session went silent.

Renaming the parent folder back to not contain any special characters fixes the problem.
Steps To Reproduce1. Move an Ardour session to a folder with a colon (':') in name
2. Try to load it
3. Watch it fail
4. Rename that folder to not have the colon in it
5. Load the session again
6. Everything back to normal
Additional InformationWhat is strange to me is that Ardour had problems with finding MIDI files in "interchange" but the session file was loaded fine!
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0020387)
x42 (administrator)
2018-09-19 15:05

A colon is interpreted as PATH separator for search paths. That is a unix standard (just like semicolon on windows).

Ardour does not allow to create or rename sessions with colon nor semicolon in the session-name.

You should always use ardour's Menu > Session > Rename function to rename sessions.
(0020388)
unfa (reporter)
2018-09-19 23:45

I'm not sure we're on the same page.

I've created an Ardour session in a path like this:

/things/Episode One/Session/Session.ardour

Then I have renamed one of the parent folders using a file manager (I couldn't do that with Ardour):

things/Episode One: Introduction/Session/Session.ardour

Which rendered the Ardour session broken.

If colon is an illegal character in a folder name, why didn't my file manager prevent me from using it?

If it's not an illegal character - I guess the problem is in how Ardour interprets the path.

- Issue History
Date Modified Username Field Change
2018-09-19 12:25 unfa New Issue
2018-09-19 15:05 x42 Note Added: 0020387
2018-09-19 15:05 x42 Status new => closed
2018-09-19 15:05 x42 Assigned To => x42
2018-09-19 15:05 x42 Resolution open => won't fix
2018-09-19 23:45 unfa Note Added: 0020388
2018-09-19 23:45 unfa Status closed => feedback
2018-09-19 23:45 unfa Resolution won't fix => reopened


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker