MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007624ardourbugspublic2018-05-24 03:522018-07-05 11:27
Reportertroathscream 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSAVlinux 2018 64bitOS Version2018
Product Version5.12 
Target VersionFixed in Version 
Summary0007624: Crash after stopping recording
DescriptionSetup audio and midi tracks for project.
Route Midi to midi track, no instrument on track.
Record enable and start recording, after pressing stop or spacebar ardour crashes and closes.
Steps To Reproduceroute midi to input of miditrack, no instrument on the track.
start recording, press stop or spacebar and ardour crashes and closes.
Additional InformationAVlinux 2018 64bit
Ardour 5.12 included with Avlinux
TagsNo tags attached.
Attached Filestxt file icon ardour-crash.txt [^] (28,751 bytes) 2018-05-24 03:52 [Show Content]
? file icon ardour-crash-alsa [^] (27,579 bytes) 2018-05-24 08:30 [Show Content]
? file icon MIDItrace [^] (13,557 bytes) 2018-07-04 08:37 [Show Content]

- Relationships

-  Notes
(0020277)
troathscream (reporter)
2018-05-24 08:32

Added the crash-log from using Alsa instead of Jack.
Using the midi track (same as with jack) to record drumtriggers through a Roland TD-3.
(0020278)
troathscream (reporter)
2018-05-25 09:31
edited on: 2018-05-30 23:03

Disabling the Rec-enable and removing the Midi input from the midi track let's me record without crashing... Seems to be something Midi related

(0020284)
troathscream (reporter)
2018-05-31 01:53
edited on: 2018-05-31 01:55

Just testted with the included Demo version of Harrison Mixbus 4.3.19 and i get the same result. It crashed when trying to record MIDI.
I used different Buffer settings in jack and Alsa but the crashes remain.

(0020324)
paul (administrator)
2018-07-04 04:51

Looks like your Roland sends a "System Reset" message, which the library we use to write+read SMF (MIDI) files doesn't understand, and it panics.
(0020325)
paul (administrator)
2018-07-04 04:56

Could you please run a MIDI monitor (or even inside Ardour, via Window > MIDI Tracer) to collect the output of your TD-3 ?
(0020326)
troathscream (reporter)
2018-07-04 04:59

He Paul, tnx for the response. As soon as i get to my rehearsal space i will perform this.
(0020327)
paul (administrator)
2018-07-04 05:01

Oh, I see ... or I think I do. The MIDI byte 0xFF is called a "system realtime" message for "system reset". I think your TD3 sends this, and Ardour records it.

But ... inside an SMF file, the MIDI byte 0xFF indicates a "meta-message", which must have at least 2 bytes following it. When we try to store the 0xFF received from the TD3 in an SMF file, the SMF-handling code throws an error, and we crash.

I'd never even heard of the system reset message until I looked it up today. Clearly, such messages cannot be stored in an SMF file. We need to handle the error better, obviously.

I'd still like to see a trace of the MIDI received from your TD3.
(0020330)
troathscream (reporter)
2018-07-04 05:09

I will send it asap
(0020339)
troathscream (reporter)
2018-07-04 08:39
edited on: 2018-07-04 09:35

Hi Paul, as requested a midi trace made with the Ardour MIDI Tracer.
And what i read somewhere is that alle Roland drum modules in the TD-range send these messages... It was something Roland exclusive, but can't remember how it is called and cant find it anymore. It is something that can't be switched off. i'll try to find out what it was called

(0020340)
troathscream (reporter)
2018-07-04 10:16
edited on: 2018-07-04 10:17

Its called Active Sensing. But don't know of this is what is causing the problems. You can find it in the midi chart page 70 in the td-3 manual

(0020341)
paul (administrator)
2018-07-04 12:21

Nope, active sense is MIDI byte 0xfe, not 0xff
(0020342)
paul (administrator)
2018-07-05 10:56

OK, ardour's master branch code is now all fixed with respect to this. It will no longer attempt to save MIDI system realtime or system common messages in an SMF file, and it will no longer crash if the library we use for handling SMF files every generates an error.

I cannot recommend that you try the current master branch, because it isn't safe to use, but the fix is now implemented and will be in the next version (no idea when that will be released).

There are two workarounds:

(1) fix your TD-3 so that it sends 0xfe and not 0xff for active sensing

(2) route the TD-3 via an ardour bus before getting to the track. In that track, insert a MIDI Event Filter plugin, from Robin Gareus' MIDI Filter plugin collection, and enable the "Block Sysex/RT message" option of that plugin. This will stop all these messages from making it to the track, and thus Ardour won't try to store them in an SMF file.
(0020343)
troathscream (reporter)
2018-07-05 11:21
edited on: 2018-07-05 11:25

Tnx paul, you are right it isnt active sensing it is indeed a reset message. I dont think the td3 has an option to disable this type of messages, so ill try your busmethod with the midi filter. I will set this bug to solved an with patience await the next Ardour release

(0020344)
troathscream (reporter)
2018-07-05 11:27

Will be fixed in next ardour release. Tnx to Paul and the Ardour team :)????

- Issue History
Date Modified Username Field Change
2018-05-24 03:52 troathscream New Issue
2018-05-24 03:52 troathscream File Added: ardour-crash.txt
2018-05-24 08:30 troathscream File Added: ardour-crash-alsa
2018-05-24 08:32 troathscream Note Added: 0020277
2018-05-25 09:31 troathscream Note Added: 0020278
2018-05-30 23:03 troathscream Note Edited: 0020278 View Revisions
2018-05-31 01:53 troathscream Note Added: 0020284
2018-05-31 01:55 troathscream Note Edited: 0020284 View Revisions
2018-07-04 04:51 paul Note Added: 0020324
2018-07-04 04:56 paul Note Added: 0020325
2018-07-04 04:59 troathscream Note Added: 0020326
2018-07-04 05:01 paul Note Added: 0020327
2018-07-04 05:09 troathscream Note Added: 0020330
2018-07-04 08:37 troathscream File Added: MIDItrace
2018-07-04 08:39 troathscream Note Added: 0020339
2018-07-04 09:35 troathscream Note Edited: 0020339 View Revisions
2018-07-04 10:16 troathscream Note Added: 0020340
2018-07-04 10:17 troathscream Note Edited: 0020340 View Revisions
2018-07-04 12:21 paul Note Added: 0020341
2018-07-05 10:56 paul Note Added: 0020342
2018-07-05 11:21 troathscream Note Added: 0020343
2018-07-05 11:25 troathscream Note Edited: 0020343 View Revisions
2018-07-05 11:27 troathscream Note Added: 0020344
2018-07-05 11:27 troathscream Status new => closed
2018-07-05 11:27 troathscream Resolution open => fixed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker