View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007566ardourbugspublic2018-02-19 11:272018-02-23 17:13
Assigned Totimbyr 
StatusresolvedResolutionno change required 
PlatformWindows 10OSOS Version
Product Version5.12 
Target VersionFixed in Version 
Summary0007566: Session "C:\Users\Greg\NAG (snapshot NAG DEMO)" did not load successfully: Failed to load state
DescriptionProgram will not open saved session. Tried backup session as well and will always get
Session "C:\Users\Greg\NAG (snapshot NAG DEMO)" did not load successfully: Failed to load state
Other sessions open correctly but not this file.
Steps To ReproduceEverytime session is opened the same message appears.
TagsNo tags attached.
Attached Fileszip file icon NAG [^] (59,733 bytes) 2018-02-19 16:07
? file icon NAG DEMO.history.bak [^] (25,947 bytes) 2018-02-22 15:59
zip file icon [^] (284,344 bytes) 2018-02-22 16:07

- Relationships
has duplicate 0007567closed Session "C:\Users\Greg\NAG (snapshot NAG DEMO)" did not load successfully: Failed to load state 

-  Notes
x42 (administrator)
2018-02-19 12:36

Can you attach the session file "NAG DEMO.ardour" -- that may indicate as to why loading fails.
gregafek (reporter)
2018-02-19 13:23

The session file was 5300k and it’s says it can only be 5000k to attach on there another way to attach it here?
gregafek (reporter)
2018-02-19 13:37

Also I changed the name from NAG DEMO to NAG to see if it would have helped,but it’s still the same file
x42 (administrator)
2018-02-19 13:50

Perhaps zipping the file can help?
Other than that, perhaps dropbox or similar cloud storage?
gregafek (reporter)
2018-02-19 16:08

Ok I zipped that file
gregafek (reporter)
2018-02-20 09:56

Any leads on that yet?
timbyr (developer)
2018-02-21 18:51

The file you have attached seems to be incomplete, so that is why it fails to load.

I'm not sure how or why the file corruption has occurred, it is like there was some sort of failure/error while writing to the file.

As this sort of issue is not something that has been reported before it may be something specific to your system.

Are the Session files you normally work with a similar size to this one?
gregafek (reporter)
2018-02-21 21:33

The other session files are usually smaller. I did get a blue screen crash on my computer at around the same time when working on the session. The blue screen cause was of bug code usb driver. I’m not sure this is related to the session being corrupted?
timbyr (developer)
2018-02-22 03:33

As far as I recall, when saving the Session state file we write to a temporary file and then only rename it once writing is successful. So it should not be possible for this to occur with a blue screen crash situation AFAIK.

There are a few possibilities, but I'm hoping it is not a recurring issue on your system. Perhaps just save a few more snapshots for a while until you can be certain.
x42 (administrator)
2018-02-22 04:17

Everything after byte 1048576 (1MB exact) in the file is zero.

It seems the file was not flushed to disk correctly. Probably due to the machine crash.
x42 (administrator)
2018-02-22 04:19

Is there a .bak backup file in the session dir? that may still have a valid session.

ie "NAG DEMO.ardour.bak"
gregafek (reporter)
2018-02-22 07:46

I do have the backup file but it doesn’t open as well.same prompts. I can upload it anyway and see what happens? Also I’m experiencing a lot of crashes with the updated ardour 5.12. Could this be related to a computer issue ?
gregafek (reporter)
2018-02-22 16:08

I just uploaded another file
This is the backup file
timbyr (developer)
2018-02-22 19:48

I can successfully load your backup Session file on Windows 7(64-bit) with Ardour 5.12.

I extracted the file into C:\Users\timbyr\NAG DEMO\NAG DEMO.ardour and then opened it from the Session Setup dialog.

It appears to open correctly(apart from the missing files) with no warnings or errors.
gregafek (reporter)
2018-02-22 20:31

That’s good news. As far as on my end,what do I need to do to open it on my computer and back into the software?
timbyr (developer)
2018-02-23 00:08

Hopefully you should just be able to rename the NAG DEMO.ardour.bak file to NAG DEMO.ardour like I did above and it should restore the Session to the backup/older copy.
gregafek (reporter)
2018-02-23 13:25

I renamed th file and saved it into original file folder. When I open from session startup , the file is not there. How do I render the backup file a “session” so the session startup box will recognize it?
gregafek (reporter)
2018-02-23 14:09

I resolved the issue. I had to view file extensions in folder and then rename that way. All is working now. Thanks for all the help!
timbyr (developer)
2018-02-23 17:13

OK, good to hear. hopefully it was a one off and will not occur again.

- Issue History
Date Modified Username Field Change
2018-02-19 11:27 gregafek New Issue
2018-02-19 12:36 x42 Note Added: 0020159
2018-02-19 13:23 gregafek Note Added: 0020160
2018-02-19 13:37 gregafek Note Added: 0020161
2018-02-19 13:50 x42 Note Added: 0020162
2018-02-19 16:07 gregafek File Added: NAG
2018-02-19 16:08 gregafek Note Added: 0020163
2018-02-19 17:20 timbyr Relationship added has duplicate 0007567
2018-02-20 09:56 gregafek Note Added: 0020165
2018-02-21 18:51 timbyr Note Added: 0020167
2018-02-21 18:51 timbyr Status new => feedback
2018-02-21 21:33 gregafek Note Added: 0020168
2018-02-21 21:33 gregafek Status feedback => new
2018-02-22 03:33 timbyr Note Added: 0020169
2018-02-22 04:17 x42 Note Added: 0020170
2018-02-22 04:19 x42 Note Added: 0020171
2018-02-22 07:46 gregafek Note Added: 0020172
2018-02-22 15:59 gregafek File Added: NAG DEMO.history.bak
2018-02-22 16:07 gregafek File Added:
2018-02-22 16:08 gregafek Note Added: 0020174
2018-02-22 19:48 timbyr Note Added: 0020176
2018-02-22 20:31 gregafek Note Added: 0020177
2018-02-23 00:08 timbyr Note Added: 0020178
2018-02-23 13:25 gregafek Note Added: 0020182
2018-02-23 13:33 gregafek Note Added: 0020183
2018-02-23 14:09 gregafek Note Added: 0020184
2018-02-23 14:09 gregafek Note Deleted: 0020183
2018-02-23 17:13 timbyr Note Added: 0020185
2018-02-23 17:13 timbyr Status new => resolved
2018-02-23 17:13 timbyr Resolution open => no change required
2018-02-23 17:13 timbyr Assigned To => timbyr

Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker