MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007456ardourbugspublic2017-08-27 02:142018-07-10 13:23
Reporteriurie 
Assigned Todrobilla 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusfeedbackResolutionreopened 
PlatformOSGNU/LinuxOS VersionDebian
Product Version5.X git (version in description) 
Target VersionFixed in Version 
Summary0007456: Error creation of symbolic link of the plugin state
Descriptiona-Fuild Synth doesn't keep the selected file after Ardour is restarted.

How reproduce:

Select a SF2 file with the /path1/file.sf2 and save. Now move the file /path1/file.sf2 to another path /path2/file.sf2. Select again from the plugin the new path. When pressing save the file will be selected and the instrument will play, but after restart you'll need to select again the file.

Also the console gives this when you save the plugin state:

lilv_file_size(): error: stat(/home/geontime/Desktop/Geontime/ideas/Seductive Moment/Seductive Moment/plugins/661788/state2/Nice-Keys-B-JNv1.5.sf2) (No such file or directory)
lilv_symlink(): error: Failed to link /home/geontime/Desktop/Geontime/ideas/Seductive Moment/Seductive Moment/externals/Nice-Keys-B-JNv1.5.sf2 => /home/geontime/Desktop/Geontime/instruments/Soundfonts/soundfonts4u/Nice-Keys-B-JNv1.5.sf2 (File exists)
 
Yes, the symbolic link exists, but the file not, since I have moved it into another path.

The problem comes probably from the lilv management of states.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0020005)
iurie (reporter)
2017-08-30 23:58

I have fixed this bug in lilv at: https://github.com/drobilla/lilv/pull/3 [^]
Waiting my pull request to be checked.
(0020006)
iurie (reporter)
2017-08-31 00:03

The issue comes form lilv, the fix is at https://github.com/drobilla/lilv/pull/3 [^]
(0020353)
drobilla (developer)
2018-07-10 13:23

The above mentioned fix removed files in the external directory, which lilv must never do. This could destroy old state that refers to files on an external drive which has been unmounted, for example.

A change that instead detects the existing broken link and creates a new one is in lilv 5e80e165754064e9942fdf7bd3449a9f4fa047a0 and should fix the issue.

- Issue History
Date Modified Username Field Change
2017-08-27 02:14 iurie New Issue
2017-08-30 23:58 iurie Note Added: 0020005
2017-08-31 00:03 iurie Note Added: 0020006
2017-08-31 00:03 iurie Status new => closed
2017-08-31 00:03 iurie Resolution open => fixed
2018-07-10 13:23 drobilla Assigned To => drobilla
2018-07-10 13:23 drobilla Note Added: 0020353
2018-07-10 13:23 drobilla Status closed => feedback
2018-07-10 13:23 drobilla Resolution fixed => reopened


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker