MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007425ardourbugspublic2017-07-13 12:142017-07-14 14:34
ReporterLost_Highway 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformLinuxOSUbuntu StudioOS Version16.04LTS
Product Version5.10 
Target VersionFixed in Version 
Summary0007425: Some plugin states not saved
DescriptionSome plugin states are not saved with the session.

Any instances of Carla Rack, after re-opening a session, there's just a blank instance of CR with none of the plugins that were loaded within when the session was saved.

Pianoteq: on re-opening a session this defaults to a particular instrument, with none of the settings (different instrument, user velocity curve etc) retained from when the session was last saved.

a-fludisynth does not retain the last loaded soundfont.

The General MIDI Synth on the other hand works fine and recalls patches when a session is reloaded.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0019885)
johmue-eo (reporter)
2017-07-14 06:33

Are there any non-ascii characters in the session path?
(0019886)
Lost_Highway (reporter)
2017-07-14 13:08

There are spaces, square brackets i.e. [ and ] and a hyphen - otherwise they're all just regular alphanumeric characters.

I've just resaved one of those session without the square brackets in the name, inserted software instruments into the empty Carla-rack instances, saved and re-opened and the session opened as expected with the instruments intact.

Has this always been an issue? I think one of the sessions was created in an earlier version of A5 and I don't recall there being issues, but I couldn't say with absolute certainty.
(0019887)
johmue-eo (reporter)
2017-07-14 13:34

Can you check which version of libserd-0-0 is installed on your system? If it's <0.26, please try to update.
(0019888)
Lost_Highway (reporter)
2017-07-14 14:34

It's 0.22. Having had a quick look, it doesn't look like any newer version of Ubuntu (I'm on 16.04 LTS) has a version newer than this.

I'll see whether I can install from the Debian repos, but I suspect I could end up in dependency hell...

- Issue History
Date Modified Username Field Change
2017-07-13 12:14 Lost_Highway New Issue
2017-07-14 06:33 johmue-eo Note Added: 0019885
2017-07-14 13:08 Lost_Highway Note Added: 0019886
2017-07-14 13:34 johmue-eo Note Added: 0019887
2017-07-14 14:34 Lost_Highway Note Added: 0019888


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker