MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007291ardourbugspublic2017-03-12 01:372017-03-12 15:28
Reporterm4l3z 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformUbuntuOSLinux MintOS Version18.1
Product Version5.8 
Target VersionFixed in Version 
Summary0007291: No GUI for the plugins samplv1, drumkv1
DescriptionThose are the only plugins in my collection for which I'm not able to show their GUI. They still work tho, I'm able to use the generic ardour controls editor.
Those plugins work fine in standalone and under the hosts Carla and Qtractor.
Ardour log returns : [ERROR]: failed to instantiate LV2 GUI
everytime I try to fire up the GUI.
They are qt-based (Qt version 5.5.1.) .
The version of the plugins is 0.8.0 and have been installed with apt through the KXStudio repository. They were working fine under ardour in the previous versions.
Steps To Reproduce1) Get the packages samplv1 samplv1-lv2 drumkv1 drumkv1-lv2 from the Kxstudio repository
2) Create a new MIDI track or AUDIO + MIDI track with one of those plugins.
3) Try to fire up the GUI or see if it's automatically opens.
Additional InformationThanks for the all the work !
Have a great day
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0019528)
x42 (administrator)
2017-03-12 09:19

This sounds like a QT4/QT5 issue.

Where did you get Ardour from?
Since version 5.8, binaries from ardour.org do include libsuil which can load qt4 and qt5 GUIs.

I have not tested KXStudio, but the QT5 vee-one plugins work here on debian with official Ardour builds.
(0019529)
m4l3z (reporter)
2017-03-12 15:28

Thanks for the answer.

I installed ardour through the KXStudio repository.
I think you are right about libsuil but the package is already installed on my computer. When running ardour from command line, this line appears when I try to fire up the GUI :
suil error: Unable to open wrap module /opt/ardour/lib/libsuil_qt5_in_gtk2.so (/usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.7' not found (required by /opt/ardour/lib/libsuil_qt5_in_gtk2.so))
I then noticed that my version of Qt was 5.5 so I installed Qt 5.7 from the official site but it didnt change anything.

- Issue History
Date Modified Username Field Change
2017-03-12 01:37 m4l3z New Issue
2017-03-12 09:19 x42 Note Added: 0019528
2017-03-12 15:28 m4l3z Note Added: 0019529


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker