MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007189ardourbugspublic2016-12-31 05:472017-04-01 06:17
Reporterkjetil 
Assigned Tox42 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionno change required 
PlatformWindowsOSWindowsOS Version10
Product Version5.5 
Target VersionFixed in Version 
Summary0007189: Ardour crashes when opening the GUI of the x42-eq stereo plugin
DescriptionSubject says it all, I guess.
Steps To Reproduce1. Insert x42-eq stereo plugin into a track
2. Open the GUI
3. Ardour crashes.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0019249)
x42 (administrator)
2016-12-31 06:34

Works here.

If you have an old[er] version of x42-eq, that would happen if your system does not support OpenGL (x42-eq crashes). Do the bundled harrison XT-* plugins show the UI?

Can you try with today's v0.5.4? http://x42-plugins.com/x42/x42-eq [^]
(0019250)
kjetil (reporter)
2016-12-31 08:08

I installed the new version by running the .exe file, but I don't see version info anywhere, so I don't know whether Ardour is actually using the new version. I did rescan though. I also tried to restart Ardour. But it still crashes as soon as the GUI becomes visible.

The harrison XT-* plugins show the UI and seems to work.
(0019251)
kjetil (reporter)
2016-12-31 08:25

Seems like I didn't install the newest version the first time. For some reason the installer didn't run. But after installing the newest version, it still crashes. But now I get two windows messages telling me that ardour.exe has crashed. Before I only got one. Don't know if this tells you anything. Let me know if there's anything else I can do to help.
(0019252)
x42 (administrator)
2016-12-31 08:42

The version info is displayed in the GUI :)

Debugging this on windows is hard. For 64bit builds: near impossible to get useful info from a stacktrace.

Maybe running Ardour from a cmd.exe will shed some light. printf() has turned out to be the least painful on 64bit windows.

Can you reproduce it with 32bit version as well? https://nightly.ardour.org/ [^] does offer a debug build (incl gdb) https://ardour.org/debugging_ardour [^]

I know that it works for other users on windows 10 (some also in the norwegian locale) so this likely something system specific which will make this harder to track down :(
(0019253)
kjetil (reporter)
2017-01-01 06:00

It crashes in 32bit as well, and I get this info from gdb (manually written down, not copy and pasted since I dont know how you copy from the console in windows):

SIGILL
(gdb) bt
#0 0x3573e4be in lv2ui_descriptor ()
   from fil4UI_gl.dll
#1 ??
#2 ??
   from fil4UI_gl.dll
#3 ??
(gdb)


This is an AMD processor. Maybe fil4UI_gl.dll is compiled for intel CPU. For instance that it's compiled with -march=native.

BTW, it's strange that you have trouble getting backtrace in 64 bit builds. For Radium, I have trouble getting backtrace in 32 bit builds. Also, you might want to look at the crashreporter directory in Radium to get backtrace sent to you whenever a user crashes the program.
(0019498)
x42 (administrator)
2017-03-06 20:16

Possibly caused by a duplicate install (Ardour windows binaries include fil4.lv2 in Program Files\Ardour5\lib\ardour5\LV2\

I've just seen a similar crash if there's a 2nd, different version in Common Files\LV2\

Really, Ardour/lilv should only pick one (and ignore the other), but there's apparently some search-path issue.

Can you check if the problem persists after removing one?
(0019536)
kjetil (reporter)
2017-03-20 09:10

Hi, I have access to the computer now (it's not my computer). Where is the "Common Files\LV2" directory supposed to? I can't find it.
(0019538)
x42 (administrator)
2017-03-22 03:27

C:\Program Files\Common Files\ (on an english system)
(0019539)
kjetil (reporter)
2017-03-22 03:34

Due to other reasons, I had to recover the computer back to initial windows 10 state. Don't know if that made the difference, or that I upgraded Ardour to 5.8, but it works now.

- Issue History
Date Modified Username Field Change
2016-12-31 05:47 kjetil New Issue
2016-12-31 06:34 x42 Note Added: 0019249
2016-12-31 08:08 kjetil Note Added: 0019250
2016-12-31 08:25 kjetil Note Added: 0019251
2016-12-31 08:42 x42 Note Added: 0019252
2017-01-01 06:00 kjetil Note Added: 0019253
2017-03-06 20:16 x42 Note Added: 0019498
2017-03-20 09:10 kjetil Note Added: 0019536
2017-03-22 03:27 x42 Note Added: 0019538
2017-03-22 03:34 kjetil Note Added: 0019539
2017-04-01 06:17 x42 Status new => resolved
2017-04-01 06:17 x42 Resolution open => no change required
2017-04-01 06:17 x42 Assigned To => x42


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker