MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006280ardourbugspublic2015-04-24 10:072017-08-04 09:12
Reporterhg87 
Assigned Tohg87 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version4.0 
Target VersionFixed in Version 
Summary0006280: Range Mode: Grid, Region bounds - no possiblity to select region aligned on 1st beat
DescriptionWhen trying to select multiple regions within the "Range Mode" with "Grid" activated, and "Region bounds" selected it is not possible to select a region which is aligned on the 1st beat.

Selection does only allow to select till the end of the region which is aligend on the 1st beat.


Kind regards,
Harald
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0017731)
hg87 (reporter)
2015-12-19 01:37

Same behaviour in 4.4-564-g7b6ef41.
(0019899)
hg87 (reporter)
2017-07-18 01:31

Just tested again with 5.10.
Still same behaviour.

It seems like the start of the first region at postion 0 is not considered to be a region boundary.
(0019920)
johmue-eo (reporter)
2017-07-22 04:00

Reproduced.

The issue occurs because Playlist::find_next_region() does not consider region boundaries == pos but only > pos. Thus it never considers pos == 0 to be a region boundary.

Proposed fix: https://github.com/Ardour/ardour/pull/367 [^]
(0019929)
johmue-eo (reporter)
2017-07-25 11:00

Fixed as of 9bfe404. Please test.
(0019953)
hg87 (reporter)
2017-08-04 09:07

@johmue-eo:
Thank you for fixing the issue.

I've tested e91821bd76b6008d9df6d5086655daa40a19275d which does work properly.
Therefore this bug can be considered fixed.
(0019954)
hg87 (reporter)
2017-08-04 09:09

http://tracker.ardour.org/view.php?id=6280#c19929 [^]
http://tracker.ardour.org/view.php?id=6280#c19953 [^]
(0019955)
hg87 (reporter)
2017-08-04 09:11

probably closing is not the best status type, it was resolved.
(0019956)
hg87 (reporter)
2017-08-04 09:12

http://tracker.ardour.org/view.php?id=6280#c19929 [^]
http://tracker.ardour.org/view.php?id=6280#c19953 [^]

- Issue History
Date Modified Username Field Change
2015-04-24 10:07 hg87 New Issue
2015-12-19 01:37 hg87 Note Added: 0017731
2017-07-18 01:31 hg87 Note Added: 0019899
2017-07-22 04:00 johmue-eo Note Added: 0019920
2017-07-22 04:00 johmue-eo Status new => confirmed
2017-07-25 11:00 johmue-eo Note Added: 0019929
2017-08-04 09:07 hg87 Note Added: 0019953
2017-08-04 09:09 hg87 Note Added: 0019954
2017-08-04 09:09 hg87 Status confirmed => resolved
2017-08-04 09:09 hg87 Resolution open => fixed
2017-08-04 09:09 hg87 Assigned To => hg87
2017-08-04 09:09 hg87 Status resolved => closed
2017-08-04 09:11 hg87 Note Added: 0019955
2017-08-04 09:11 hg87 Status closed => feedback
2017-08-04 09:11 hg87 Resolution fixed => reopened
2017-08-04 09:12 hg87 Note Added: 0019956
2017-08-04 09:12 hg87 Status feedback => assigned
2017-08-04 09:12 hg87 Status assigned => resolved
2017-08-04 09:12 hg87 Resolution reopened => fixed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker