Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004579 [ardour] bugs tweak always 2011-12-20 15:18 2013-01-26 16:15
Reporter naptastic View Status public  
Assigned To paul
Priority normal Resolution not fixable  
Status resolved   Product Version 3.X git (version in description)
Summary 0004579: Connection manager won't connect MIDI track outputs to hardware MIDI outputs
Description Connection manager should be able to connect the output from a MIDI track to the physical output of my sound card (or A2Jmidi) but this is not allowed; those connections have to be made from the mixer or project window, which takes forever if you've got a lot to make.
Additional Information Please see the attached the screenshot. The bottom-right hand section of the connection matrix should not be grayed out.
Tags No tags attached.
Attached Files png file icon Screenshot-Audio Connection Manager.png [^] (78,759 bytes) 2011-12-20 15:18

Sponsor -  Users sponsoring this issue
Sponsors List Total Sponsorship = US$ 100

2011-12-20 15:19: naptastic (US$ 100)

- Relationships

-  Notes
(0012434)
cth103 (administrator)
2011-12-21 05:59

That is the audio connection manager; it is not intended to allow connection of MIDI ports. Does the MIDI connection manager work?

Since MIDI ports started getting a representation in audio port matrices it is debateable whether this is a silly restriction ...
(0012456)
naptastic (reporter)
2011-12-26 11:28

The MIDI connection manager does work, AFAICT. I'd rather have everything in one window, though; keeping it open and in the background on a 1920x1200 screen, and referring to it for making connections is way easier than anything else, and having one for MIDI and one for audio seems silly to me; just "grey out" the options that aren't possible and call it a day.
(0013065)
wicked_boy (reporter)
2012-04-02 00:53

I personally prefer it the way it is now.. I have over 20 MIDI ports ... so it is too confusing if it is on the one page..
(0013067)
colinf (updater)
2012-04-02 05:35

What about just separating the 'Ardour Tracks' tab into 'Ardour Audio Tracks' & 'Ardour MIDI Tracks' tabs?
(0013076)
naptastic (reporter)
2012-04-03 21:34

Colinf's suggestion makes more sense and would be preferable to me, rather than having whole separate windows for audio and MIDI connections.
(0013078)
colinf (updater)
2012-04-04 06:31

Ah, having thought about it a bit more, I'm not sure my idea makes any more sense than having separate audio & MIDI connection managers.

Since audio sources can only ever be connected to audio destinations, and MIDI sources to MIDI destinations likewise, selecting a MIDI tab for a source and an audio tab for a destination will only ever show completely greyed-out connection possibilities.

In other words, I don't think there's any point in trying to unify the audio & MIDI connection managers by displaying MIDI and audio together in the same grid.

Perhaps the audio & MIDI connection managers could be combined into one window, with some means to switch the view between audio & MIDI, though.
(0014221)
paul (administrator)
2012-11-12 13:46

"not fixable" because nobody really knows what to do (for now). maybe its not a bug at all. maybe it needs a completely new idea.

- Issue History
Date Modified Username Field Change
2011-12-20 15:18 naptastic New Issue
2011-12-20 15:18 naptastic File Added: Screenshot-Audio Connection Manager.png
2011-12-20 15:19 naptastic Sponsorship Added naptastic: US$ 25
2011-12-20 15:19 naptastic Sponsorship Total 0 => 25
2011-12-20 15:19 naptastic Issue Monitored: naptastic
2011-12-21 05:59 cth103 Note Added: 0012434
2011-12-21 05:59 cth103 Status new => feedback
2011-12-26 11:28 naptastic Note Added: 0012456
2011-12-26 16:24 cth103 cost => 0.00
2011-12-26 16:24 cth103 Target Version => 3.0
2012-02-27 11:41 naptastic Sponsorship Updated naptastic: US$ 75
2012-02-27 11:41 naptastic Sponsorship Total 25 => 75
2012-02-27 11:41 naptastic Sponsorship Updated naptastic: US$ 100
2012-02-27 11:41 naptastic Sponsorship Total 75 => 100
2012-04-02 00:53 wicked_boy Note Added: 0013065
2012-04-02 05:35 colinf Note Added: 0013067
2012-04-03 21:34 naptastic Note Added: 0013076
2012-04-04 06:31 colinf Note Added: 0013078
2012-04-24 17:03 cth103 Status feedback => acknowledged
2012-11-12 13:46 paul Note Added: 0014221
2012-11-12 13:46 paul Status acknowledged => resolved
2012-11-12 13:46 paul Resolution open => not fixable
2012-11-12 13:46 paul Assigned To => paul
2013-01-26 16:15 naptastic Issue End Monitor: naptastic


Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker