MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002392ardourbugspublic2008-09-18 12:212010-04-24 03:31
Reporterrealhangman 
Assigned Tov2 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.8 
Summary0002392: "Consolidate Region" applies effects - this is an unexpected and dangerous behaviour
DescriptionThe 2.5 Release notes read:



'- add "Consolidate Range" which writes a new audio file and uses it to replace whatever was in the playlist within the range'



This is midleading. I worked on a project and thought that "consolidate region" would merge all region in a range to one new region without touching the material in gain or other manner. Later, I was stuck because the consolidated region was quieter than the rest of my material - the feature took the volume of the track into account (which was at -1.5, so I first didn't notice it).
Additional InformationIt is very fiddly to always deactivate all plugins on a track and adjust the volume back to -0.0 before consolidating. If my bug report describes the wanted behaviour, an standard option to consolidate without applying volume and effects would be good.
TagsNo tags attached.
Attached Files

Sponsor - Users sponsoring this issue
Sponsors List Total Sponsorship = US$ 51

2008-10-31 11:22: realhangman (US$ 5)
2008-11-16 14:03: melkhorn (US$ 46)

- Relationships

-  Notes
(0005157)
thorgal (reporter)
2008-10-06 06:05

not that I entirely disagree, but how would you manage cross-overs (overlaps between regions) ?
(0005158)
realhangman (reporter)
2008-10-06 06:36

Hi,
I'm not sure if I understand you correctly, but arent' cross-overs crossfades? I would just leave them as you hear them - just do the consolidation pre-fader and pre- pre-effects. So only apply region-gain, nothing more.

I'll try to visit the irc channel today so we could clarify things if this isn't what you've asked for.

Benjamin
(0005159)
thorgal (reporter)
2008-10-06 07:46

did I say cross-"over" ? yeah, I meant cross-FADE ... :P
but this needs clarification, because if you want to consolidate them "as you hear them", what about the rest of the regions if you do have FX on them ? then you crossfade you hear is ALSO affected by them, so this is not clear how you want this to be done. Note that I am not a dev!!! just a user like you who would like the best out of any effort regarding this matter.
(0005160)
thorgal (reporter)
2008-10-06 07:47

I really type like crap today ...
(0005161)
realhangman (reporter)
2008-10-06 08:03

Hi,
ok, you're right, this needs clarification, "as you hear them" was pretty bad formulated ;)

My approach to use consolidation is this: I edit a region or various overlaying regions until I'm finished editing. Editing means to me "no effects" just cut the music until it's ok for what I need. This includes crossfades. Then I consolidate (bounce) all the regions so that I won't have a track with hundreds of regions but only one.
Therefore I'm using this consolidate feature as a quick bounce feature.

If, along the way, I start using effects on this track, I don't want them to be applied in the consolidation, because then, they would be applied twice - once during the consolidation, once more via my effects in the track which are of course still active.

Maybe this clarifies what I mean. I would apply region gain and crossfades (everything within the regions) but nothing from the track settings.
When I first used the consolidate feature, I never thought that the track settings would touch the new created region, since these are completely different things (and again, the track settings stay the way they are, therefore touching the region again when you activate the playback).

Maybe there could be 2 consolidate options: (1) "consolidate regions" and (2) "consolidate regions with track settings".
(0005232)
melkhorn (reporter)
2008-11-16 13:56

I'll second realhangman's assertion that the default behavior for consolidate region should be before effects. Conceptually, the line drawn would be between "editing" and "mixing," where varous regions with crossfades are comp'd together would, in my view, be primarily edit decisions, and effects would be mix decisions. I realize that there is some grey area there, but the consolidation should include upto any redirects, to include effects.

Imagine you've compiled some drum takes, shoved some kick hits around, and produced a "good" one. now, to facilitate easier editing of the drumset as a whole, you want to consolidate so that every kit element (kick, snare, tom1, etc.) has regions of the same length. If consolidate was post-effects, then suddenly all of your carefully set gates (for example) would be shot, and you'd have to re-do them.
(0005233)
melkhorn (reporter)
2008-11-16 14:02

Oh, yeah. For the time being, I recommend deactivating any plugins before consolidating. Both for the above reasons, but also, some plugins will totally screw up a consolidation into an unusable mess. Bouncing, too, for that matter (which consolidating is, really). Disabling them works.
(0005241)
zettberlin (reporter)
2008-11-18 11:57

I really like the possibility to apply effects. If you have a really large project this can help a lot to decrease system load and to make it easier to control the session. It also adds a new approach to the workflow-possibilities that makes Ardour a better tool for sound design - if I want 2 seconds of a guitar to sound really freaked out, I want it - no need to revert the results later and thus I can make use of a dozen of plugins on 2-3 seconds of a track and remove the plugins afterwards...

But nonetheless the idea to have the option to disable the plugins if needed is good - choice is always cool ;-)
(0005245)
realhangman (reporter)
2008-11-19 02:20

Thanks for all the feedback.

I agree with zettberlin that it's a good feature to have (apply with effects and volume of the track) - but I say that the description is misleading. People who want to combine regions like in other DAWs might end up with total frustration.
So having both options (with track settings and without) would be cool.

melkhorn: You not only have to disable the effects on the channel, but also set the volume back to 0.0.
(0005867)
v2 (developer)
2009-04-08 22:32

This has been fixed in 2.8. There are now options to consolidate with or without processing.

Can you please test and confirm it behaves the way you need it to?
(0005874)
realhangman (reporter)
2009-04-10 01:14

Hi v2,

sorry for reopening this issue, I don't know how else to reply.

It works perfectly! Only region gain automations and crossfades are taken into account, no effects or faders. 100% as I wished for!
The german translation lags behind, but that's a very minor thing (and has nothing to do with this report).

Thank you very much, you can close this again!
Benjamin
(0005888)
seablade (manager)
2009-04-11 13:16

Resolving the issue out as it appears to be fixed in 2.8 Don't forget to arrange for the sponsorship amount to be taken care of if you sponsored the issue:) Have fun.

    Seablade

- Issue History
Date Modified Username Field Change
2008-09-18 12:21 realhangman New Issue
2008-10-06 06:05 thorgal Note Added: 0005157
2008-10-06 06:36 realhangman Note Added: 0005158
2008-10-06 07:46 thorgal Note Added: 0005159
2008-10-06 07:47 thorgal Note Added: 0005160
2008-10-06 08:03 realhangman Note Added: 0005161
2008-10-31 11:22 realhangman Sponsorship Added realhangman: US$ 5
2008-10-31 11:22 realhangman Sponsorship Total 0 => 5
2008-11-16 13:56 melkhorn Note Added: 0005232
2008-11-16 14:02 melkhorn Note Added: 0005233
2008-11-16 14:03 melkhorn Sponsorship Added melkhorn: US$ 20
2008-11-16 14:03 melkhorn Sponsorship Total 5 => 25
2008-11-18 11:57 zettberlin Note Added: 0005241
2008-11-19 02:20 realhangman Note Added: 0005245
2009-04-08 15:03 melkhorn Sponsorship Updated melkhorn: US$ 26
2009-04-08 15:03 melkhorn Sponsorship Total 25 => 31
2009-04-08 15:10 melkhorn Sponsorship Updated melkhorn: US$ 46
2009-04-08 15:10 melkhorn Sponsorship Total 31 => 51
2009-04-08 22:32 v2 cost => 0.00
2009-04-08 22:32 v2 Status new => resolved
2009-04-08 22:32 v2 Resolution open => fixed
2009-04-08 22:32 v2 Assigned To => v2
2009-04-08 22:32 v2 Note Added: 0005867
2009-04-10 01:14 realhangman Status resolved => feedback
2009-04-10 01:14 realhangman Resolution fixed => reopened
2009-04-10 01:14 realhangman Note Added: 0005874
2009-04-11 13:16 seablade Note Added: 0005888
2009-04-11 13:16 seablade Status feedback => resolved
2009-04-11 13:16 seablade Fixed in Version => 2.8
2009-04-11 13:16 seablade Resolution reopened => fixed
2010-04-24 03:28 cth103 Category bugs => bugs2
2010-04-24 03:31 cth103 Category bugs2 => bugs


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker