MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001423ardourbugspublic2007-01-13 11:402011-09-28 04:33
Reporterallan_k 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusconfirmedResolutionreopened 
PlatformOSOS Version
Product VersionSVN/2.0-ongoing 
Target Version2.8.13Fixed in Version 
Summary0001423: MIDI controller maps fails to reload
DescriptionAfter every time I re-open ardour2 the MIDI control mapping fails to load and the following error is recorded in console.

ardour: [WARNING]: Generic MIDI control: controllable 1168373434 not found in session (ignored)


TagsNo tags attached.
Attached Files? file icon ard2-test.ardour [^] (13,176 bytes) 2007-01-15 15:42

- Relationships

-  Notes
(0003062)
allan_k (reporter)
2007-01-13 11:41

oops the last line should read

Ardour/GTK 2.0beta10
   (built using 1266 and GCC version 4.1.1 (Gentoo 4.1.1-r1))
(0003063)
paul (administrator)
2007-01-15 09:35

what was the control that was mapped?

please attach the session file to the bug.
(0003065)
allan_k (reporter)
2007-01-15 10:14

Hardware wise it was with a bcf2000

MIDI wise
It was channel 1,

in this instance it was taken from a list of a few and could be anything from CC 25-32 or 65 - 71.

I just reproduced it, but using a different track and got a different number. This was channel 1 CC 0 to a channel fader

ardour: [WARNING]: Generic MIDI control: controllable 369 not found in session (ignored)

and on a subsequent repeat again channel 1 controller 0

ardour: [WARNING]: Generic MIDI control: controllable 369 not found in session (ignored)

hope this helps
(0003066)
allan_k (reporter)
2007-01-15 10:16

this is the most recent session file, that was used with the more recent bugs added.
(0003069)
paul (administrator)
2007-01-15 11:00

no session file attached, still.
(0003072)
allan_k (reporter)
2007-01-16 06:12

is this what you need Paul?

If not, let me know which file do you need? (what extension)
(0003158)
ryan_scott (reporter)
2007-02-03 13:40

I'm having the same issue.

Paul do you need something other than the .ardour file that's attached to this ticket or is that sufficient?
(0003369)
paul (administrator)
2007-02-23 08:16

folks, i can't reproduce this at all. the code surrounding this stuff has changed a bit since this was reported. could i ask you both to try it out again and see if the same exists? if it does, please post the .ardour file
(0004924)
kayosiii (reporter)
2008-05-13 05:42

Got the same behaviour here - tested 2.3 and 2.4.1 Releases....

Specifically I get this problem with "recenable" events all my other events stay in tact and work fine...
(0006237)
seablade (manager)
2009-07-03 22:22

Is this still an issue in recent(2.8 or newer) versions of Ardour?
(0006738)
cth103 (administrator)
2009-10-19 15:24

Closing due to lack of feedback from the reporter.
(0007060)
nettings (manager)
2009-11-01 09:24

bindings for mixer faders and panners are restored correctly, but not for plugins as of r5993.


(0007061)
Dubphil (reporter)
2009-11-01 09:34

Same issue with GLAME butterworth lowpass filter and TAP Stereo echo

- Issue History
Date Modified Username Field Change
2007-01-13 11:40 allan_k New Issue
2007-01-13 11:41 allan_k Note Added: 0003062
2007-01-15 09:35 paul Note Added: 0003063
2007-01-15 09:35 paul Status new => feedback
2007-01-15 10:14 allan_k Note Added: 0003065
2007-01-15 10:16 allan_k Note Added: 0003066
2007-01-15 11:00 paul Note Added: 0003069
2007-01-15 15:42 allan_k File Added: ard2-test.ardour
2007-01-16 06:12 allan_k Note Added: 0003072
2007-02-03 13:40 ryan_scott Note Added: 0003158
2007-02-23 08:16 paul Note Added: 0003369
2008-05-13 05:42 kayosiii Note Added: 0004924
2009-07-03 22:22 seablade Note Added: 0006237
2009-07-03 22:22 seablade Description Updated
2009-07-03 22:22 seablade Additional Information Updated
2009-10-19 15:24 cth103 cost => 0.00
2009-10-19 15:24 cth103 Note Added: 0006738
2009-10-19 15:24 cth103 Status feedback => resolved
2009-10-19 15:24 cth103 Resolution open => unable to reproduce
2009-10-19 15:24 cth103 Assigned To => cth103
2009-11-01 09:24 nettings Note Added: 0007060
2009-11-01 09:24 nettings Status resolved => confirmed
2009-11-01 09:24 nettings Resolution unable to reproduce => reopened
2009-11-01 09:24 nettings Description Updated
2009-11-01 09:34 Dubphil Note Added: 0007061
2011-09-28 04:33 cth103 Assigned To cth103 =>
2011-09-28 04:33 cth103 Product Version => SVN/2.0-ongoing
2011-09-28 04:33 cth103 Target Version => 2.8.13


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker